ログを表示するには

ログビューアー

「ログビューアー」では、運用時にサービスに接続して、フローサービスで出力されるログを確認できます。ログ内容の検索や、フィルター機能によって条件に一致した行だけを取り出すことが可能です。また、ログの解析機能を使って、フローの実行状況も確認できます。

ログビューアーでログを表示する

1.「ツール」メニューの「ログビューアー」を選択してログビューアーを起動する

8-166-01.png

 

2.接続先のサーバーアイコンを右クリックし、「接続」を選択する

8-166-02.png

 

HINT

サーバーを追加するには
新規にサーバーを追加するには、「ファイル」メニューの「サーバーを追加」を選択し、表示される「ログイン」ダイアログでサーバー情報とユーザー情報を指定して、「OK」をクリックして接続します。

 

3.「ログイン」ダイアログでログイン情報を確認し「OK」をクリックすると、ツリーペインに項目一覧が表示されるので、項目をダブルクリックして展開していき、ログを表示する

8-166-03.png

ツリーペインで、サーバーやログの種類をダブルクリックすると項目が展開表示され、ログ一覧が表示されます。ログ一覧で「最新」または日付をダブルクリックすると、右側のウィンドウにログの詳細が表示されます。

 

HINT

ログビューアーを起動するその他の方法
Windowsの「スタート」メニューから「ASTERIA WARP - Flow Designer」-「ログビューアー」を選択して起動することもできます。

 

アプリケーションログを表示する

1.「アプリケーションログ」の「+」記号をクリックして展開し、表示される一覧でログ設定名の「最新」をダブルクリックする

8-166-04.png

右側の一覧に、指定したアプリケーションログの一覧が表示されます。
なお、アプリケーションログの一覧が表示されるのは、アプリケーションログのログ設定名が定義されていて、フローやコンポーネントのログ出力で、アプリケーションログが指定されている場合です。

 

HINT

アプリケーションログの設定名は、FSMC(フローサービス管理コンソール)を使って定義する必要があります。システムログやアプリケーションログの表示、検索などの操作は、FSMCでも実行できます。

ログの内容を検索するには
フィルターペインの「検索文字列」ボックスに検索対象の文字列を入力して「Enter」キーを押すと、「メッセージ」列の内容にその文字列を含むログだけが右側に一覧表示されます。すべての列を検索対象にするには、「全フィールド対象」にチェックマークを付けてから検索を実行します。なお、「メッセージ」列を対象に検索するだけなら、ログビューアーのメニューの下にある「検索」ボックスも利用できます。

ログビューアーを終了するには
ログビューアーの「ファイル」メニューの「終了」を選択するか、もしくは右上の「×」(閉じる)ボタンをクリックします。

 

フィルターでログを絞り込む

1.ログビューアーの「表示」メニューで「フィルター」を選択する

8-166-05.png

 

2.フィルターペインが表示されるので、それぞれの項目を使って表示対象のログを指定する

8-166-06.png

 

3.カテゴリーを指定するには、「カテゴリー」の一覧でカテゴリを選択する

8-166-07.png

「カテゴリー」の一覧では、フロー名を選択して、特定のフローのログのみ表示することもできます。フィルターペインの「フィルター行のみ表示」が選択されていれば、フィルターで該当した行のみが、右側の一覧に表示されます。

 

HINT

フィルターペインの表示をやめるには、フィルターペイン右上の「×」(閉じる)ボタンをクリックします。

 

FlowService.logのログ解析を実行する

1.ログビューアーのツリーペインで、解析対象のFlowService.logの一覧を開いて表示し、「ツール」メニューの「FlowServiceログを解析」をクリックする

8-166-08.png

 

2.「FlowServiceログを解析」ダイアログが表示されるので、解析の時間間隔を選択し、「実行」をクリックする

8-166-09.png

実行されたフローの実行回数や、最大処理時間を時間帯ごとに確認できます。時間帯の行をクリックすると、「フロー集計レポート」欄に実行状況が表示されます。

 

ログ解析をファイルに出力する

1.「FlowServiceログを解析」ダイアログの「レポート出力」でレポートの種類を選択し、「ヘッダをつける」の項目を指定して、「ファイル出力」をクリックする

8-166-10.png

2.「保存」ダイアログでファイルの保存先とファイル名を指定して保存する

8-166-11.png

解析結果は、CSV形式のファイルとして保存されます。「FlowServiceログを解析」ダイアログで「ヘッダをつける」にチェックマークを付けると、出力結果に項目名が付加されます。
作業が終了したら、「FlowService ログを解析」ダイアログの右上に表示されている「キャンセル」、または「×」(閉じる)ボタンをクリックしてダイアログを閉じます。

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
    キーワード:
  • デバッグ
  • アプリケーションログ
  • フローの実行
  • ログビューアー
  • ログ解析
他にご質問がございましたら、リクエストを送信してください

このセクションの記事

他のキーワードで検索する