マッピング定義を見やすくするには

レイヤーの利用

マッピングウィンドウでは、複数のレイヤーを使用できます。複雑なマッピングをいくつかのレイヤーに分けて定義することで、マッピング定義が見やすくなります。ウィンドウの下部にあるレイヤータブを使って、レイヤーの追加や削除、切り替え表示ができます。

レイヤーを追加する

1.マッピングウィンドウの下に表示されている「+」ボタンをクリックする

 

HINT

レイヤーとは、複雑なマッピングをいくつかに分けて定義してマッピング情報を見やすくするための、ページのようなものです。マッピングウィンドウの下部にタブでレイヤー名が表示され、タブを切り替えることでそれぞれのレイヤーを表示できます。

レイヤーを追加するその他の方法
マッピングウィンドウで右クリックして表示されるメニューから「レイヤーの追加」を選択しても同様に操作できます。

 

2.「レイヤーの追加」ダイアログでレイヤー名を指定し、「OK」をクリックする

レイヤーが追加され、新しいレイヤーのタブが表示されます。

 

HINT

レイヤーを削除するには
削除したいレイヤーを表示し、マッピングウの下に表示されている「×」ボタンをクリックします。

 

関数を別のレイヤーに表示する

1.関数が配置されているレイヤーを表示する

 

2.対象の関数を右クリックして、メニューから「他のレイヤーに送る」を選択、次に表示先のレイヤーを選択する

 

HINT

元のレイヤーへ戻すには
移動した関数を元のレイヤーに戻すには、フローデザイナーウィンドウのツールバーで「元に戻す」ボタンをクリックするか、または、移動先のレイヤーで関数を右クリックし、「他のレイヤーに送る」メニューから元のレイヤーを選択します。

 

3.移動先のレイヤーを表示するには、下のタブからレイヤーを切り替える

このようにして、選択した関数だけを別のレイヤーに移動できます。複数の関数を選択しておけば一括で移動することも可能です。

 

HINT

レイヤーを切り替えるには、マッピングウィンドウ下部の各レイヤーのタブをクリックしますが、幅が狭く操作しづらいときは、マッピング領域の左右の境界をドラッグすることで、幅を広げることができます。

すべてのレイヤーを一度に表示するには
マッピング領域で右クリックして、表示されるメニューの「すべてのレイヤーを表示」を選択します。「すべてのレイヤーを表示」メニューをクリックするたびに、すべてのレイヤーの表示とそれぞれのレイヤーの表示に切り替わります。

 

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
    キーワード:
  • レイヤー
  • マッパー
  • マッピング定義
他にご質問がございましたら、リクエストを送信してください

このセクションの記事

他のキーワードで検索する