ASTERIA WARP 4.7 - 4.9.1 動作環境

※バージョン4.8.1はバージョン4.8と同じです。バージョン4.7.1はバージョン4.7と同じです。以前のバージョンはこちら

●ASTERIA WARP / ASTERIA WARP Lite 推奨スペック

CPU Quad Core CPU 以上
メモリ 4GB 以上
HDD 1TB 以上


上記スペックは「推奨」であり、上記要件を満たしていない環境でもサーバーのオペレーティングシステムの システム要件を満たしていれば動作させることは可能となります。最適なスペックは、主に処理内容、その実行頻度、 データ量によって異なりますので、以下の無料体験版を利用して確認されることをお勧めいたします。
https://www.infoteria.com/jp/contact/asteria/trial/

●フローサービス動作環境 

対応オペレーティングシステム フローデザイナー対応オペレーティングシステム
対応データベース フローサービス管理コンソール推奨プラウザ
対応アプリケーション ActiveDirectory
対応通信プロトコル  

◎サーバー環境

対応オペレーティングシステム

バージョン 4.7 4.8 4.9 4.9.1
Microsoft Windows Server 2003 R2 Standard / Enterprise / Datacenter    
Microsoft Windows Server 2008 Standard / Enterprise / Datacenter  
Microsoft Windows Server 2008 R2 Standard / Enterprise / Datacenter
Microsoft Windows Server 2012 Standard / Essentials / Foundation / Datacenter  
Microsoft Windows Server 2012 R2 Standard / Essentials / Foundation / Datacenter  
Microsoft Windows XP Professional (SP3以降)      
Microsoft Windows Vista Ultimate / Business / Enterprise      
 Microsoft Windows 7 Professional / Ultimate / Enterprise
 Microsoft Windows 8 / Pro / Enterprise
 Microsoft Windows 8.1 / Pro / Enterprise  
 Microsoft Windows 10 / Pro / Enterprise    
Oracle Solaris 10 SPARC / x86      
Red Hat Enterprise Linux 5 Advanced Platform / base server    
Red Hat Enterprise Linux 6
Red Hat Enterprise Linux 7 (*5)  
CentOS 6
CentOS 7    
Ubuntu 12.04 LTS    
Ubuntu 14.04 LTS    
Amazon Linux    

[2017年2月現在]

*1 特に記述がない場合は32bit版/64bit版の両方に対応
 (OSがどちらかのみに対応している場合は対応しているもののみ)
*2 Windowsで特に記述がない場合は最新SPに対応
*3 Red Hat Enterprise Linuxで特に記述がない場合は最新Updateに対応
*4 Javaベンダーが正式にサポートしていないOSバージョンにつきましても、弊社の検証により動作対象として問題ないと判断した場合は動作環境としています。この場合、問題が起きた場合にそれがOSとJavaのバージョンに起因する場合は弊社では対応できないこともありますのでご了承ください。
*5 ASTERIA WARP 4.8.1から対応

【クラウドと仮想環境での動作について】
 クラウドおよび仮想環境での利用については、使用する環境において上記のOSのサポートを行っている場合は利用することができます。ただし、クラウド、仮想環境下特有の障害が発生した場合は制限事項となる可能性があります。詳細は以下をご確認ください。
https://support.asteria.com/hc/ja/articles/229288448

対応データベース

バージョン 4.7 4.8 4.9 4.9.1
Oracle 8i / 9i / 9i R2 / 10g    
Oracle 10g R2 / 11g / 11g R2
Oracle 12c  
IBM DB2 V9.5    
IBM DB2 V9.7
IBM DB2 10.1
IBM DB2 10.5  
IBM AS/400 iSeries DB2 V5R1 / V5R2 / V5R3 / V5R4      
IBM AS/400 iSeries DB2 V6R1 / V7R1
IBM AS/400 iSeries DB2 V7R2    
PureData System for Analytics (Netezzaテクノロジー) (*6)
Microsoft SQL Server 2005 / 2008 / 2008 R2 / 2012
Microsoft SQL Server 2014 (*7)  
Microsoft SQL Server 2016      
Azure SQL Database
Microsoft Access 2003 (*8)      
Microsoft Access 2007 (*8) (*10) (*10)
Microsoft Access 2010 / 2013 (*9) (*9) (*10) (*10)
Microsoft Access 2016       (*10)
PostgreSQL 8.3      
PostgreSQL 8.4    
PostgreSQL 9.0 / 9.1 / 9.2
PostgreSQL 9.3  
PostgreSQL 9.4    
PostgreSQL 9.5      
MySQL 5.0 / 5.1      
MySQL 5.5
MySQL 5.6  
MySQL 5.7      
MariaDB 10.0  
FileMaker Server 9 / 10      
FileMaker Server 12 / 13  
FileMaker Server 14      
Amazon Aurora    

[2017年2月現在]

*6 ASTERIA WARP 4.7.1から対応
*7 ASTERIA WARP 4.8.1から対応
*8 ASTERIA WARP 32bit版のみ対応
*9 64bit版では一部問題のある場合が有ります。以下のリンクを合わせてご確認ください。
 https://support.asteria.com/hc/ja/articles/229077507
*10 接続するためには別途JDBCドライバーが必要です。

対応アプリケーション

バージョン 4.7 4.8 4.9 4.9.1
Microsoft Excel 2003      
Microsoft Excel 2007 / 2010 / 2013
Microsoft Excel 2016    
Lotus Notes/Domino 8.0 (*11)    
Lotus Notes/Domino 8.5 (*11)
Lotus Notes/Domino 9 (*11)  
NeoCoreXMS 3.1
Dr.Sum EA Ver3.0 / Ver3.0 SP1 / Ver3.0 SP2 / Ver3.0 SP3 (*12)
Dr.Sum EA Ver4.0 / Ver4.0 SP1 (*12)
Dr.Sum EA Ver4.1 (*12)    
Amazon Redshift    
IBM WebSphere MQ V7.0
IBM WebSphere MQ V7.1 / V7.5 / 8.0    
Tableau 9      

[2017年2月現在]

*11 NotesGetAdv,NotesPutAdvコンポーネントはWindows 32bit版のみ対応。
 フローサービスをインストールした環境にNotesクライアントが必要です。バージョン4.8以前はフローデザイナーをインストールした環境にもNotesクライアントが必要です。
 NotesRESTGet,NotesRESTPut,NotesRESTViewGetコンポーネントはASTER WARP 4.9.1以降、かつLotus Notes/Domino 9にのみ対応しています。
*12 Windows版のみ対応。Ver3.0 SP2はバージョン4.4、Ver3.0 SP3はバージョン4.5、Ver4.0 SP1はバージョン4.9から対応。Ver3.0以降のみASTERIA WARP 32bit/64bit版で対応。
*その他、オプションアダプターにて対応しているものについては以下の紹介サイトをご確認ください。
  https://www.infoteria.com/jp/warp/feature/option/

対応通信プロトコル

バージョン 4.7 4.8 4.9 4.9.1
HTTP / HTTPS
SMTP / SMTPS
POP3 / POP3S
IMAP / IMAPS
FTP / SFTP (*13)
LDAP
SOAP 1.1
SOAP 1.2    

[2017年2月現在]

*13 SFTPはパスワード認証、公開鍵認証に対応

◎クライアント環境

フローデザイナー対応オペレーティングシステム

バージョン 4.7 4.8 4.9 4.9.1
Microsoft Windows Server 2003 R2    
Microsoft Windows Server 2008 / 2012  
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012 R2  
Microsoft Windows XP Professional (SP3以降)      
Microsoft Windows Vista      
Microsoft Windows 7
Microsoft Windows 8 / Pro / Enterprise
Microsoft Windows 8.1 / Pro / Enterprise  
Microsoft Windows 10 / Pro / Enterprise    

[2017年2月現在]

*14 特に記述がない場合は最新SPに対応
*15 32bit版/64bit版のOS両方に対応。64bit版OSでは、32bitアプリケーションとして動作します。
*16 NotesGetAdv,NotesPutAdvコンポーネントを使用する場合、バージョン4.8以前はフローデザイナーにNotesクライアントが必要で、32bitOS上で実行する必要があります。
*17 Excelアダプター、PDFアダプターを使用する場合、フローデザイナーをインストールした環境に32bit版Excelが必要です。

フローサービス管理コンソール推奨ブラウザ

バージョン 4.7 4.8 4.9 4.9.1
Microsoft Internet Explorer 6 SP1 / 7 / 8 / 9      
Microsoft Internet Explorer 10  
Microsoft Internet Explorer 11  
Microsoft Edge    
Firefox 4 以降
Google Chrome
iPad版Safari  

[2017年2月現在]

ActiveDirectory

バージョン 4.7 4.8 4.9 4.9.1
Microsoft Windows Server 2008 / 2012 (*18)  
Microsoft Windows Server 2008 R2 / 2012 R2 (*18)
AWS Directory Service    

[2017年2月現在]

*18 LDAPコンポーネントで接続可能

 

●パイプラインサービス動作環境 

対応オペレーティングシステム パイプラインコーディネーター推奨プラウザ
対応データベース  
対応アプリケーション  
対応通信プロトコル  

◎サーバー環境

対応オペレーティングシステム

バージョン 4.7 4.8 4.9 4.9.1
Microsoft Windows Server 2003 R2 Standard / Enterprise / Datacenter    
Microsoft Windows Server 2008 Standard / Enterprise / Datacenter  
Microsoft Windows Server 2008 R2 Standard / Enterprise / Datacenter
Microsoft Windows Server 2012 Standard / Essentials / Foundation / Datacenter  
Microsoft Windows Server 2012 R2 Standard / Essentials / Foundation / Datacenter  
Microsoft Windows XP Professional (SP3以降)      
Microsoft Windows Vista Ultimate / Business / Enterprise      
 Microsoft Windows 7 Professional / Ultimate / Enterprise
 Microsoft Windows 8 / Pro / Enterprise
 Microsoft Windows 8.1 / Pro / Enterprise  
 Microsoft Windows 10 / Pro / Enterprise    
Oracle Solaris 10 SPARC / x86      
Red Hat Enterprise Linux 5 Advanced Platform / base server    
Red Hat Enterprise Linux 6
Red Hat Enterprise Linux 7 (*5)  
CentOS 6
CentOS 7    
Ubuntu 12.04 LTS    
Ubuntu 14.04 LTS    
Amazon Linux    

[2017年2月現在]

*1 特に記述がない場合は32bit版/64bit版の両方に対応
 (OSがどちらかのみに対応している場合は対応しているもののみ)
*2 Windowsで特に記述がない場合は最新SPに対応
*3 Red Hat Enterprise Linuxで特に記述がない場合は最新Updateに対応
*4 Javaベンダーが正式にサポートしていないOSバージョンにつきましても、弊社の検証により動作対象として問題ないと判断した場合は動作環境としています。この場合、問題が起きた場合にそれがOSとJavaのバージョンに起因する場合は弊社では対応できないこともありますのでご了承ください。
*5 ASTERIA WARP 4.8.1から対応

【クラウドと仮想環境での動作について】
 クラウドおよび仮想環境での利用については、使用する環境において上記のOSのサポートを行っている場合は利用することができます。ただし、クラウド、仮想環境下特有の障害が発生した場合は制限事項となる可能性があります。詳細は以下をご確認ください。
https://support.asteria.com/hc/ja/articles/229288448

対応データベース

バージョン 4.7 4.8 4.9 4.9.1
Oracle 10g    
Oracle 10g R2 / 11g / 11g R2
Oracle 12c  
IBM DB2 V9.5    
IBM DB2 V9.7 / 10.1
IBM DB2 10.5  
IBM AS/400 iSeries DB2 V5R1 / V5R2 / V5R3      
IBM AS/400 iSeries DB2 V5R4      
IBM AS/400 iSeries DB2 V6R1 / V7R1
IBM AS/400 iSeries DB2 V7R2    
Microsoft SQL Server 2005 / 2008 / 2008 R2 / 2012
Microsoft SQL Server 2014 (*6)  
Microsoft Access 2003 (*7)      
Microsoft Access 2007 (*7) (*9) (*9)
Microsoft Access 2010 / 2013 (*8) (*8) (*9) (*9)
Microsoft Access 2016       (*9)
PostgreSQL 8.3      
PostgreSQL 8.4    
PostgreSQL 9.0 / 9.1 / 9.2
PostgreSQL 9.3  
PostgreSQL 9.4    
PostgreSQL 9.5      
MySQL 5.0 / 5.1      
MySQL 5.5
MySQL 5.6  
MySQL 5.7      

[2017年2月現在]

*6 ASTERIA WARP 4.8.1から対応
*7 ASTERIA WARP 32bit版のみ対応
*8 64bit版では一部問題のある場合が有ります。以下のリンクを合わせてご確認ください。
 https://support.asteria.com/hc/ja/articles/229077507
*9 接続するためには別途JDBCドライバーが必要です。

対応アプリケーション

バージョン 4.7 4.8 4.9 4.9.1
Microsoft Excel 2003      
Microsoft Excel 2007 / 2010 / 2013 (*10)
Microsoft Excel 2016 (*10)      

[2017年2月現在]

*10 4.9.1からxlsx形式に対応。それ以外のバージョンはxlsx形式は未対応

対応通信プロトコル

バージョン 4.7 4.8 4.9 4.9.1
HTTP / HTTPS
SMTP / SMTPS
POP3 / POP3S
FTP / SFTP (*11)
SOAP 1.1
SOAP 1.2        

[2017年2月現在]

*11 SFTPはパスワード認証のみ

◎クライアント環境

パイプラインコーディネーター推奨ブラウザ

バージョン 4.7 4.8 4.9 4.9.1
Microsoft Internet Explorer 7 / 8      
Microsoft Internet Explorer 9 (*12) (*12) (*12)  
Microsoft Internet Explorer 10 (*12) (*12) (*12) (*12)  
Microsoft Internet Explorer 11   (*12) (*12) (*12)
Microsoft Edge 未対応 
Firefox 4 以降
Google Chrome 未対応

[2017年2月現在]

*12 互換モードのみ対応、一部動作しない機能あり

 

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
    キーワード:
  • 動作環境
他にご質問がございましたら、リクエストを送信してください

このセクションの記事

他のキーワードで検索する